Thingsboard thingsboard 编译报错,不知什么原因,求救

hunter · 2020年08月18日 · 最后由 sds 回复于 2020年09月07日 · 204 次阅读

[[WARNING] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\watchpack-chokidar2\node_modules\fsevents): [INFO] added 1647 packages from 1455 contributors in 234.562s

[WARNING] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

[WARNING] npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules\fsevents):

[WARNING] npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

[ERROR]

[INFO]

[INFO] 59 packages are looking for funding

[INFO] run npm fund for details

[INFO]

[INFO]

[INFO] --- frontend-maven-plugin:1.7.5:npm (npm build) @ ui-ngx ---

[INFO] Running 'npm run build:prod' in D:\work\thingsboard\ui-ngx

[INFO]

[INFO] > thingsboard@3.0.1 build:prod D:\work\thingsboard\ui-ngx

[INFO] > ng build --prod --vendor-chunk

[INFO]

[ERROR] Compiling @angular/animations : module as esm5

[ERROR] Compiling @angular/core : module as esm5

[ERROR] Compiling @angular/animations/browser : module as esm5

[ERROR] Compiling @angular/animations/browser/testing : module as esm5

[ERROR] Compiling @angular/common : module as esm5

[ERROR] Compiling @angular/cdk/clipboard : module as esm5

[ERROR] Compiling @angular/cdk/platform : module as esm5

[ERROR] Compiling @angular/cdk/bidi : module as esm5

[ERROR] Compiling @angular/cdk/collections : module as esm5

[ERROR] Compiling @angular/cdk/scrolling : module as esm5

[ERROR] Compiling @angular/cdk/drag-drop : module as esm5

[ERROR] Compiling @angular/common/http : module as esm5

[ERROR] Compiling @angular/common/http/testing : module as esm5

[ERROR] Compiling @angular/flex-layout/core : module as esm5

[ERROR] Compiling @angular/platform-browser : module as esm5

[ERROR] Compiling @angular/flex-layout/extended : module as esm5

[ERROR] Compiling @angular/flex-layout/flex : module as esm5

[ERROR] Compiling @angular/flex-layout/grid : module as esm5

[ERROR] Compiling @angular/flex-layout : module as esm5

[ERROR] Compiling @angular/cdk/keycodes : module as esm5

[ERROR] Compiling @angular/cdk/observers : module as esm5

[ERROR] Compiling @angular/cdk/a11y : module as esm5

[ERROR] Compiling @angular/platform-browser/animations : module as esm5

[ERROR] Compiling @angular/forms : module as esm5

[ERROR] Compiling @angular/material/core : module as esm5

[ERROR] Compiling @angular/cdk/portal : module as esm5

[ERROR] Compiling @angular/cdk/overlay : module as esm5

[ERROR] Compiling @angular/material/form-field : module as esm5

[ERROR] Compiling @angular/material/autocomplete : module as esm5

[ERROR] Compiling @angular/material/badge : module as esm5

[ERROR] Compiling @angular/cdk/layout : module as esm5

[ERROR] Compiling @angular/material/bottom-sheet : module as esm5

[ERROR] Compiling @angular/material/button-toggle : module as esm5

[ERROR] Compiling @angular/material/card : module as esm5

[ERROR] Compiling @angular/material/checkbox : module as esm5

[ERROR] Compiling @angular/material/chips : module as esm5

[ERROR] Compiling @angular/cdk/accordion : module as esm5

[ERROR] Compiling @angular/material/expansion : module as esm5

[ERROR] Compiling @angular/material/grid-list : module as esm5

[ERROR] Compiling @angular/material/icon : module as esm5

[ERROR] Compiling @angular/material/icon/testing : module as esm5

[ERROR] Compiling @angular/material/divider : module as esm5

[ERROR] Compiling @angular/material/list : module as esm5

[ERROR] Compiling @angular/material/menu : module as esm5

[ERROR] Compiling @angular/material/progress-bar : module as esm5

[ERROR] Compiling @angular/material/progress-spinner : module as esm5

[ERROR] Compiling @angular/material/radio : module as esm5

[ERROR] Compiling @angular/material/sidenav : module as esm5

[ERROR] Compiling @angular/material/slide-toggle : module as esm5

[ERROR] Compiling @angular/material/slider : module as esm5

[ERROR] Compiling @angular/material/button : module as esm5

[ERROR] Compiling @angular/material/snack-bar : module as esm5

[ERROR] Compiling @angular/cdk/stepper : module as esm5

[ERROR] Compiling @angular/material/stepper : module as esm5

[ERROR] Compiling @angular/cdk/table : module as esm5

[ERROR] Compiling @angular/material/select : module as esm5

[ERROR] Compiling @angular/material/tooltip : module as esm5

[ERROR] Compiling @angular/material/paginator : module as esm5

[ERROR] Compiling @angular/material/sort : module as esm5

[ERROR] Compiling @angular/material/table : module as esm5

[ERROR] Compiling @angular/material/tabs : module as esm5

[ERROR] Compiling @angular/material/toolbar : module as esm5

[ERROR] Compiling @angular/cdk/tree : module as esm5

[ERROR] Compiling @angular/material/tree : module as esm5

[ERROR] Compiling @angular/core/testing : module as esm5

[ERROR] Compiling @angular/platform-browser-dynamic : module as esm5

[ERROR] Compiling @angular/platform-browser/testing : module as esm5

[ERROR] Compiling @angular/compiler/testing : module as esm5

[ERROR] Compiling @angular/platform-browser-dynamic/testing : module as esm5

[ERROR] Compiling @angular/common/testing : module as esm5

[ERROR] Compiling @angular/router : module as esm5

[ERROR] Compiling @angular/router/testing : module as esm5

[ERROR] Compiling @auth0/angular-jwt : module as esm5

[ERROR] Compiling @flowjs/ngx-flow : module as esm5

[ERROR] Compiling @angular/material/dialog : module as esm5

[ERROR] Compiling @angular/cdk/text-field : module as esm5

[ERROR] Compiling @angular/material/input : module as esm5

[ERROR] Compiling @angular/material/datepicker : module as esm5

[ERROR] Compiling @mat-datetimepicker/core : module as esm5

[ERROR] Compiling @ngrx/store : module as esm5

[ERROR] Compiling @ngrx/effects : module as esm5

[ERROR] Compiling @ngrx/effects/testing : module as esm5

[ERROR] Compiling @ngrx/store/testing : module as esm5

[ERROR] Compiling @ngrx/store-devtools : module as esm5

[ERROR] Compiling @ngx-share/core : module as esm5

[ERROR] Compiling @ngx-translate/core : module as esm5

[ERROR] Compiling @ngx-translate/http-loader : module as esm5

[ERROR] Compiling angular-gridster2 : module as esm5

[ERROR] Compiling angular2-hotkeys : module as esm5

[ERROR] Compiling ngx-window-token : module as esm5

[ERROR] Compiling ngx-clipboard : module as esm5

[ERROR] Compiling ngx-color-picker : module as esm5

[ERROR] Compiling ngx-daterangepicker-material : module as esm5

[ERROR] Compiling ngx-hm-carousel : module as esm5

[ERROR] Compiling ngx-translate-messageformat-compiler : module as esm5

[ERROR]

[ERROR] Compiling ngx-flowchart : module as esm5

[INFO]

[INFO] chunk {} runtime.6feb887df07fce63b89a.js (runtime) 1.46 kB [entry] [rendered]

[ERROR]

[INFO] chunk {1} main.e29f4efbe71b2e527978.js (main) 128 bytes [initial] [rendered]

[ERROR] WARNING in Invalid constructor parameter decorator in D:/work/thingsboard/ui-ngx/node_modules/ngx-flowchart/dist/ngx-flowchart/fesm2015/ngx-flowchart.js:

[INFO] chunk {2} polyfills.58a5fd1dd6d7d916bda4.js (polyfills) 25.1 kB [initial] [rendered]

ERROR => []

[INFO] chunk {3} polyfills-es5.bdfc16373bb872b3c64f.js (polyfills-es5) 86.8 kB [initial] [rendered]

[ERROR]

[ERROR] ERROR in getInternalNameOfClass() called on a non-ES5 class: expected FcModelValidationService to have an inner class declaration

[INFO] chunk {4} styles.847f14359bb6ee347331.css (styles) 300 kB [initial] [rendered]

[INFO] chunk {scripts} scripts.5bafdae4331650149d6f.js (scripts) 1.29 MB [entry] [rendered]

[INFO] Date: 2020-08-18T12:49:57.537Z - Hash: 26bea29f21b964c1cb22 - Time: 37073ms

[ERROR] npm ERR! code ELIFECYCLE

[ERROR] npm ERR! errno 1

[ERROR] npm ERR! thingsboard@3.0.1 build:prod: ng build --prod --vendor-chunk

[ERROR] npm ERR! Exit status 1

[ERROR] npm ERR!

[ERROR] npm ERR! Failed at the thingsboard@3.0.1 build:prod script.

[ERROR] npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

[ERROR]

[ERROR] npm ERR! A complete log of this run can be found in:

[ERROR] npm ERR! C:\Users\hunter\AppData\Roaming\npm-cache_logs\2020-08-18T12_49_57_748Z-debug.log

[INFO] ------------------------------------------------------------------------ [INFO] Reactor Summary: [INFO] [INFO] Thingsboard 3.0.1-SNAPSHOT ......................... SUCCESS [ 1.637 s] [INFO] Netty MQTT Client .................................. SUCCESS [ 2.813 s] [INFO] Thingsboard Server Commons ......................... SUCCESS [ 0.286 s] [INFO] Thingsboard Server Common Data ..................... SUCCESS [ 4.133 s] [INFO] Thingsboard Server Common Utils .................... SUCCESS [ 0.461 s] [INFO] Thingsboard Server Common Messages ................. SUCCESS [ 1.850 s] [INFO] Thingsboard Actor system ........................... SUCCESS [ 1.136 s] [INFO] Thingsboard Server Queue components ................ SUCCESS [ 8.165 s] [INFO] Thingsboard Server Commons ......................... SUCCESS [ 0.070 s] [INFO] Thingsboard Server Common Transport components ..... SUCCESS [ 1.464 s] [INFO] Thingsboard MQTT Transport Common .................. SUCCESS [ 1.328 s] [INFO] Thingsboard HTTP Transport Common .................. SUCCESS [ 0.865 s] [INFO] Thingsboard CoAP Transport Common .................. SUCCESS [ 1.025 s] [INFO] Thingsboard Server Common DAO API .................. SUCCESS [ 1.519 s] [INFO] Thingsboard Extensions ............................. SUCCESS [ 0.528 s] [INFO] Thingsboard Rule Engine API ........................ SUCCESS [ 1.062 s] [INFO] Thingsboard Server DAO Layer ....................... SUCCESS [ 7.388 s] [INFO] Thingsboard Rule Engine Components ................. SUCCESS [ 5.105 s] [INFO] Thingsboard Server Transport Modules ............... SUCCESS [ 0.104 s] [INFO] Thingsboard HTTP Transport Service ................. SUCCESS [ 14.442 s] [INFO] Thingsboard MQTT Transport Service ................. SUCCESS [ 13.044 s] [INFO] Thingsboard CoAP Transport Service ................. SUCCESS [ 15.445 s] [INFO] ThingsBoard Server UI .............................. FAILURE [05:46 min] [INFO] Thingsboard Server Tools ........................... SKIPPED [INFO] Thingsboard Rest Client ............................ SKIPPED [INFO] ThingsBoard Server Application ..................... SKIPPED [INFO] ThingsBoard Microservices .......................... SKIPPED [INFO] ThingsBoard Docker Images .......................... SKIPPED [INFO] ThingsBoard JavaScript Executor Microservice ....... SKIPPED [INFO] ThingsBoard Web UI Microservice .................... SKIPPED [INFO] ThingsBoard Node Microservice ...................... SKIPPED [INFO] ThingsBoard Transport Microservices ................ SKIPPED [INFO] ThingsBoard MQTT Transport Microservice ............ SKIPPED [INFO] ThingsBoard HTTP Transport Microservice ............ SKIPPED [INFO] ThingsBoard COAP Transport Microservice ............ SKIPPED [INFO] ThingsBoard Black Box Tests 3.0.1-SNAPSHOT ......... SKIPPED [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 07:12 min [INFO] Finished at: 2020-08-18T20:49:58+08:00 [INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:1.7.5:npm (npm build) on project ui-ngx: Failed to run task: 'npm run build:prod' failed.

org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value: 1) -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

[ERROR]

[ERROR] After correcting the problems, you can resume the build with the command

[ERROR] mvn -rf :ui-ngx

这个错误不影响吧,能运行起来吗?

不行,编译通不过,终止了

hunter 回复

UI 都是网络问题,只有保证能访问 google 的情况下,不断的重试,每次重试记得清理 node 残留文件,在 UI 目录下面

终于通过了,谢谢

hunter 回复

太难了

sds 关闭了讨论 09月07日 11:30
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册